Pokemon Go will only work on Android 4.3+ or iPhone 5 ( and above )

Pokemon Go will only work on Android 4.3+ or iPhone 5 ( and above )

    

Niantic Games has already started registration for testing a preliminary Beta version of Pokemon Go  ( The Upcoming Real World Pokemon Game for Android and iOS ) in Japan .




For now Pokemon Go Beta version will only work on Android 4.3 or greater , while iOS devices needs atleast iPhone 5 to Play Pokemon Go .

source



0 comments:

Subscribe to our newsletter to get the latest updates to your inbox.